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Chapter I: CMS-Basics 
Here you will find a description of the basic functions of the CMS, which you should keep in 
mind when editing all pages in the CMS. 

1. Preparations 
 

 

                            Figure 1: Login screen in Fiona 7 

 Log in to the CMS with your bt identifier and password: 
https://www.cms.uni-bayreuth.de/default/NPS/login  
 

 Editorial advice & assistance is available from the central online editorial team, Anne 
Schraml and Christopher Reimelt, onlineredaktion@uni-bayreuth.de  
 

 Tips and tricks for using the CMS can also be found here: https://www.intranet.uni-
bayreuth.de/de/allgemein/onlineredaktion/index.php 
 

 Technical support and CMS training can be obtained from Oliver Gschwender, CMS 
support, cms@uni-bayreuth.de 
 
Current training dates can be found on this page:  
https://www.its.uni-bayreuth.de/cms-betreuung#d5d87b1d 
 

 For information on writing rights in the CMS, please contact Markus Barnick, 
markus.barnick@uni-bayreuth.de, 0921 / 55-3230 

Please note: Changes that you make independently to the programming of the templates can 
lead to incorrect displays or unintentional interactions with future updates. After such changes, 
neither the IT Service Center nor the Press, Marketing and Communications (PMK) service center 
can guarantee unrestricted functionality or provide troubleshooting support. 
  

https://www.cms.uni-bayreuth.de/default/NPS/login
mailto:onlineredaktion@uni-bayreuth.de
https://www.intranet.uni-bayreuth.de/de/allgemein/onlineredaktion/index.php
https://www.intranet.uni-bayreuth.de/de/allgemein/onlineredaktion/index.php
mailto:cms@uni-bayreuth.de
https://www.its.uni-bayreuth.de/cms-betreuung#d5d87b1d
mailto:markus.barnick@uni-bayreuth.de
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2. Presets in CMS 
 Set the „Projector“ scheme under „Extras“ > „Personal Preferences“ > “Colors & Fonts”. 

 
 Under „View“ > „Show Files“, tick all files except „Layouts“. 

 
 In the CMS, find the path to your website. If you do not already have a CMS folder, 

please contact the online editorial team (onlineredaktion@uni-bayreuth.de). Then 
bookmark your site: „Bookmarks“ > „Add Bookmark“. 
 
 

3. Views 
 
Via „View“ (alternatively via the corresponding buttons, see. Fig. 2) you can choose 
between the views „Tree“, „Columns“, „Table“, „Icons“, „Details“ und „Preview“. The 
following views are relevant for you: 
 
 Columns: In the column view, you can see the respective page properties on the right 

side of your screen and edit them. In addition, you can see the publishing status of a 
file in this view (see: I.9.2) 

 Table: In the table view you can select several files at once, e.g. to share or move them. 
 Details: In the detail view you will find further information about the website, for 

example about admin rights or links to the page in question. 
 Preview („Editor“): In the editor view you have the possibility to design your page. If 

you are creating a new page, this will most likely be your most frequently selected 
view.  

 Separate Preview: You get a live preview of your page, where you can test links, for 
example. Editing is not possible in this view. We recommend that you always check 
your page in the Separate Preview before you share it. 

 
Figure 2: Icons (from left): Tree, Column, Table, Icons and Detail view, Preview ("Editor") and Separate preview. 

 

  

mailto:onlineredaktion@uni-bayreuth.de
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4. When changing views: always refresh! 
 
If you switch from the editor view to another view after editing - without updating - the 
changes you have just made may not yet be displayed if no update has been made yet. 
Therefore: Always refresh when you want to make a view change via the "Refresh" button 
or via "View" > "Refresh"! 
 

 
Figure 3: The „Refresh“ button 
 

 

5. Folder names 
 
Please always write the „Name“ oft he individual folders in the CMS in small letters and if 
possible with short keywords, as this will later be part of the URL. For example: 
www.xyz.uni-bayreuth.de/en/research (Folder name: research) is easier to type than 
www.xyz.uni-bayreuth.de/en/research-on-the-topic-XY-2012-to-2022 (Ordnername: 
Research-On-The-Topic-XY-2012-To-2022).  

Please write the „Title“ of the page normally, i.e. capitalized for nouns: Research.  

How to create new folders is explained in detail in the corresponding chapters later in the 
manual.  
 

 

6. Relevant templates 
 
In the CMS, there are customized blueprints for different purposes of use. You can find the 
exact usage in the corresponding chapters. 
 

6.1. Page Templates 
 unibt_standard: The most frequently used and most flexibly designable page template 
 unibt_publikationen: Overview page for publications (see chapter IV.1, p. 31 f.) 
 unibt_mitwirkende: Overview of team members in list form (see IV.2.3, p. 34) 
 unibt_person: Person one page template (see chapter IV.2.3, p. 34) 
 unibt_blaupause_newsordner: News overview page (see chapter IV.3, p. 36) 
 unibt_blaupause_newsmeldung:  Single news story template (see chapter IV.3, p. 36 f.) 
 unibt_event_uebersicht: Overview page displaying your events that you have 

previously uploaded to the CMS as an event. (see IV.4, p. 37) 
 unibt_event: Event template (see IV.4, p. 38) 
 btcms_hidden: Pool Subfolder Template 
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6.2. Picture templates 
 Slider image: The image that is at the top of a home page, image dimensions: 1100 x 

440 px. (see chapter II.2 resp. II.3) 
 Banner image: The image that is at the top of pages below the home page, image 

dimensions: 1100 x 440px. (see chapter I.6.1) 
 UNI-BT image: Default template for all images to be placed on a page via text-image 

modules (see chapter I.6.1) 

 

7. Uploading pictures in CMS 
7.1 The right image sizes for your website 
If you want to upload images for your website, please sort out the copyrights in advance 
and make sure that each image does not exceed 300 KB. Larger images can have a 
negative impact on your website load time, which in turn can have a negative impact on 
Google ranking. For banner images, it is also important that they are resized to 1100x440 
pixels before uploading. It is best to use an image editing program such as Gimp for this. 
Only png or jpg files should be uploaded to the CMS. 

7.2 Import and refresh files in CMS 
Then go to the „pool“ folder in the CMS in the column view and from there to „bilder“. Click 
on „file“ > „import file“. A new window opens. 

Select the desired image via „choose file“. With the option „Create a new file in the folder 
‚bilder‘“ you create a new file. Then „Import“. 

Please note: The option „The current version of the file ‚xyz‘ will be replaced“ 
will overwrite a file that you have previously selected.  

In the next step, select the correct template: For standard images choose „UNI-BT Bild“, for 
banner images „Bannerbild“.  

Please note: Slider images on start pages have a different procedure, which is 
explained in more detail in points II.1.2 (Chair) and II.1.3 (Faculty). 

  



5 
 

7.3. Alt-Texts and other properties 
Go to the column view and fill in the fields „unibt_alttext” (mandatory!), 
„unibt_bild_copyright“ and „unibt_bildunterschrift“ for standard images under „Overview“ 
> „Flipside“. For banner images, only the "unibt_alttext" is mandatory. Then release (see 
point I.12). 
 

 
Figure 4: Setting of a UNI-BT standard image. 

 

Alternative image descriptions or alt texts enable visually impaired people to grasp the 
content of images on a website. To ensure that websites are used with as few barriers as 
possible, the alt text for images is a mandatory field. This means that images can only be 
shared if the alt text is filled in.   

Bonus point: Alt texts are also rated positively by Google. 

But what is an alt text actually? In the field of the alt text you enter what you see on the 
photo or graphic. For example "Logo of the University of Bayreuth", "Rondell of the 
University of Bayreuth" or "Prof. Dr. Stefan Leible". 

The alternative text should be an adequate substitute for an image so that the page 
content is understandable without photos or graphics and still provides the same 
information content. Limit yourself to a description of the image content, without 
interpretation. If it is a photo of a person (e.g. on your team page), the alt text corresponds 
to the name of the person pictured. The text should be brief. 

Two examples (with several possibilities): 

  

 Prof. Dr. Stefan Leible 
 Portrait picture of Prof. Dr. Stefan Leible, President of the University of Bayreuth 
 Prof. Dr. Stefan Leible, President of the University of Bayreuth. The picture was taken in 

front of a wall in the Applied Computer Science building. 
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 Rondell of the University of Bayreuth 
 Rondell of the University of Bayreuth at Bayreuth campus in bird’s eye view 
 Rondell of the University of Bayreuth at the campus in Bayreuth, where paved paths 

lead to a paved square inside, with lawn in between. Leafy trees grow around the 
rondel. 

8. Modules 
 
You can build your website in the preview ("Eye") using a modular system. Various 
modules are available for this purpose, these three types are the most common: the text-
image module, the link-list module and the accordion module. You can easily drag and 
drop the modules onto the page in the preview. 

Please note: The full selection of modules is only available on pages with the template 
"UNI-BT: Standard Seite". 

 

Figure 5: Module-Center in the preview 
 

8.1. Text-Image-Modules 
 
Text-image modules are the basic tool for website maintenance. They hold text and, if 
needed, one image each. 

Proceed as follows:  

Select the desired page in the column view and switch to the preview ("Eye"). 

Then drag and drop as many text-image modules onto the page as you expect to need. 

Click in the text-image module. A cogwheel appears in the left corner, which you click on. 
A new window opens in which you can maintain an image link, a caption and the image 
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alignment, among other things (see Figs. 6 and 7).

 

Figure 6: Text-Image-Module in the preview 

 

Figure 7: Setting options of a text-image module 

There are two ways to insert an image.  

1.  drag and drop the desired image from your desktop into the corresponding text 
image module. The image will automatically be imported into your images folder in 
the pool. Then go to the images folder and enter the alt text of the image there 
(mandatory field!). Then release. To avoid image duplications, you should always 
use this method only once for bilingual pages.  

2. Link an image that you have already imported and shared in your image folder in 
the pool using the cogwheel.  
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Format text:  

Paste your text into the text-image module. As soon as you click with the mouse cursor in 
the text field, a formatting bar appears with which you can, for example, bold texts, insert 
green headings (Formatierungsstil > Grüne Überschrift (green heading)) or place separator 

lines.  

Figure 8: Formatting bar 

 

Linking is also possible with the formatting bar: select text passage > click on „chain“-icon 
in the formatting bar> enter „Title“ > „Destination“: link desired page via CMS Fiona or 
copy external link into the field > set „Frame“ (see below) > OK 
 
In general, the following applies to the „Frame“: 
1. Linking within the appearance: "Default" (= same window). 
2. Documents: „New window“ 
3. Linking to external websites or websites outside of the respective appearance: „New 
window“ 
4. Mail address: „New windowr“ (prefix the link target with mailto:,  
e.g. mailto:onlineredaktion@uni-bayreuth.de) 

 

Figure 9: Edit link 

Please note: If you do not allow a link to an external page to open in a new window, you 
will not be able to test the link in Separate Preview. 
 

8.2. Linklist-Module 
 
The link list module can be used to create link lists of any length. To do this, go back to the 
preview ("Eye") and drag and drop a link list module from the module center. You can add 
as many links as you like via the black button "Link hinzufügen" (Add link). In this case, 
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please always assign a link title, as the link title will be displayed in the link list.

 
Figure 10: Linklist-Module 

 

8.3. Accordion-Modules 
 
Another option on standard pages are accordion modules (unfold function). Here, only the 
headings of the individual texts are displayed, the texts themselves are only unfolded by 
clicking this heading. 

 

Figure 11: Filled accordion module 

To do this, go back to the preview ("Eye") and drag and drop an accordion module from 
the module center. 

Once you have inserted an accordion via the Module Center and refreshed the page, you 
can add new elements via the black "Akkordeonelement hinzufügen” (Add Accordion 
Element) button. 

Insert image: Each accordion element can display a maximum of one image. Use the drag 
& drop function again here, with which you drag the image from your desktop into the 
accordion element, or the gear wheel with which you link an image that you have 
previously imported into the pool of your page (cf. procedure under I.7.1 to I.7.3; do not 
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forget "Alt text"!).

 

Figure 12: Editing accordion module 
 

Tip: Sometimes the gear wheel does not appear with newly inserted accordion modules. 
Then it is helpful to refresh the page (see Chapter I.4). 

9. Putting content online 
 

9.1 Options for release 
 

After you have made all the changes in the CMS, they still need to be released. There are 
two ways to do this: 

a) "Workflow" > "Finish Editing": Here you will see all the files that you have edited. Check 
the ones you want to share and click "Continue" > "Ok". 

This sharing method is best when you want to share multiple changes at once. 

b) "Workflow” > “Release”: Select a file that you want to share and share it via Workflow > 
Release. If "Release" is grayed out, you may have to apply the version via "Workflow" > 
"Take". 

This release method is best when you want to release individual changes.  
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9.2. Release status 
 

In the column view, you will see a small dot in front of each file, be it a folder, an image, 
a document or a module. 

 White: File is not released. 
 Black-White: There is a released version of this file, however, changes have been made 

in the meantime that have not yet been released. 
 Black: The (latest version of this) website is released and thus online.  

 

Chapter II - Home page 
 
When designing the start page of a website, it depends on which blueprint you are 
working with: For chairs, project groups and events the "blueprint project chair" is used, for 
faculties the "blueprint project faculty". 
 

1. General Settings 
 

The general settings are the same for both templates. To do this, go to the column view. 

• Page title: Go to your start page folder, i.e. "de" for German-language websites or "en" 
for English-language websites. Enter the chair name in the properties under "Common" 
> "Title". 

 
Figure 133: Putting chair name as Title 
 

• Person responsible for the page: Decide who should be the editor and thus the 
contact person on the pages. Enter the bt- or s-identifier under "verantwortlich" 
(responsible). Attention: Group identifiers (bt4...) are not possible here. Afterwards 
you can still edit the name to be displayed as well as the deposited mail address 
and insert e.g. a function mail address.  
Please think of a solution that is as sustainable as possible! The person responsible 
for the website should be employed for a longer period of time. 
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Figure 14: Fill in the responsible person 
 

 Social media buttons: Add your chair-specific information/links, such as Twitter 
presence or YouTube channel, under " Configuration". Please only do this if the 
corresponding accounts are available - the university channels are preset..  
 

 

         Figure 15: Insert links to your social media accounts 

 
 Logo linking: You can integrate your own logo next to the university logo. Important: 

It cannot be larger than the university logo. Due to the different designs of logos, there 
is no fixed size requirement..  
 
Load the image file (cf. I.7.1. to I.7.3.) of your logo into the pool (template: "UNI-BT 
image"; do not forget "Alt text"). Then switch back to the start page folder "de" or "en" 
in the column view. Link the image under "Link to logo". If it is the logo of another 
institution, e.g. the Elitenetzwerk Bayern, you can also set a link to this external page 
under "Link to homepage of chair". Please select the frame "New window" when setting 
the link. 

 

         Figure 16: Linking a second logo. 

 

 Special case of monolingual websites: On a monolingual website, no language 
switcher may be displayed. To do this, go to the "de" or the "en" folder > 
"Configuration". For purely German-language sites, link to the "de" folder under 
"unibt_siblinglink_de", and for purely English-language sites, link to the "en" folder 
under "unibt_siblinglink_en". 

 

         Figure 17: Mark website as monolingual 
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 Sitetool links: Sitetool links are legally binding and are maintained by the central 
online editorial team (Onlineredaktion). They include the accessibility and privacy 
policy, the sitemap, the imprint, the house rules, and a link to your contact page. 
 

 Quick start: Under "Configuration" > "unibt_schnelleinstieg" you can include external 
service links: for example, to a research institute with which you collaborate, or similar. 
Note: Please always select the "New window" frame when linking to external websites. 
 
SEO description (search engine optimization): The attribute "unibt_seoDescription" 
can be found at the "de"-/ "en"-folder under "configuration". Here you enter a short 
description of your department/project. For all other pages below the start page, you 
will find the corresponding field under "flipside". 
 
Note: The SEO description is a suggestion for Google, which the search engine can 
adopt, but does not have to. Which snippet (text in search results) is displayed also 
depends on the search query, as the following example shows: 
 
„entrepreneurship uni bayreuth“ 
 

 

             Figure 18: Google Snippet 1 
 

         „iei uni bayreuth“ 

 

           Figure 19: Google Snippet 2 
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2. Design start page in chair template 
 

You have the choice: 

 Start page without or with (multiple) slider(s) 
 Start page with news and/or appointment box 

 

 

Figure 20: Example of a start page with slider and newsbox 

2.1 Slider images on start page 
 

You can set either a fixed slider or multiple sliders to cycle through on your home page. 
Please note that no text box appears on the sliders of the chair template. This is only 
possible with the faculty template. 

 

 

 

Slider 

 

Newsbox 

Figure 21: Edit slider 
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 When using the images, please ensure that you have clarified the rights of use: 
Copyright of the photographer and personal rights of the persons depicted. 
 

 Customize the images: jpg format, RGB colors, 1100 pixels (px) width by 440 pixels 
height (crop with e.g. Gimp or Photoshop). The image should be under 300 KB, 
otherwise the loading time of your website will increase. 
 

 Select the folder "de" or "en" in the column view and import the images one after the 
other into the selected folder: "File" > "Import file“ 
 
Select the option "Create a new file in the folder 'de'" or "Create a new file in the folder 
'en'". Use "Datei auswählen" (Import) to select the corresponding image. Then click on 
"Import". 
 
Select the "Slider Image" template. 
 
Assign "Name" and "Title". Please always write the name in small letters and without 
umlaut. Examples: s01-research, s02-team 
 
Note: Based on the name, the sliders are sorted. This way you can determine the order 
of the sliders on the live page.  
  

 Please add an "Alt text" to the slider images under "Overview > "content". The alt 
attribute describes what can be seen on the image (see Chapter I.7.3). Maintaining the 
alt texts is mandatory. If they are not entered properly, you will not be able to share the 
images. 
 

 The slider images can be linked to subpages via "Overview > "content" > "unibt_link" 

2.2. Link newsbox and/or event box on home page 
 
With the chair template you have the possibility to place a preview of your news and/or 
your events in boxes directly on the start page. To do this, proceed as follows: 

 Create a news or event folder (for procedure see Chapter IV.3 or IV.4). 
 Go to the column view. Under "Overview" > "configuration" you will find the options 

"ubt_config_link_news" or "ubt_config_link_events". Link there to the previously 
created news or event page. 

 Select the option "Ja" (Yes) for "showNewsTeaser" and/or "showEventTeaser". 

 

 
Figure 22: In this case only the news box is displayed. 

Note: The 5 most recent news or the 5 most recent events of the current year are displayed 
in the teasers. Past events are not displayed. 
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3. Design start page in faculty template 
 

 

Figure 23: Homepage of faculty of biology, chemistry & earth sciences 

 

 

 

 

3.1. Slider image(s) on the start page 
 

You can set either one fixed slider or several sliders on your home page, which will 
scroll. 
 

 When using the images, please ensure that you have clarified the rights of use: 
Copyright of the photographer and personal rights of the persons depicted. 
 

Slider 

Teaserbox 
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 Customize the images: jpg format, RGB colors, 1100 pixels (px) width by 440 pixels 
height (crop with e.g. Gimp or Photoshop). The image should be under 300 KB, 
otherwise the loading time of your website will increase. 
 

 Select the folder "de" or "en" in the column view and import the images one after the 
other into the selected folder: "File" > "Import file“ 
 
Select the option "Create a new file in the folder 'de'" or "Create a new file in the folder 
'en'". Use "Datei auswählen" (Import) to select the corresponding image. Then click on 
"Import". 
 
Select the "Slider Image" template. 
 
Assign "Name" and "Title". Please always write the name in small letters and without 
umlaut. Examples: s01-research, s02-team 
 
Note: Based on the name, the sliders are sorted. This way you can determine the order 
of the sliders on the live page.  
 

 Under "Overview" > "content", fill in the "Title", "unibt_teasertext" and "unibt_link" 
fields. Please also add an "unibt-alttext". The Alt attribute describes what can be seen 
on the image (see Chapter I.7.3). Maintaining the alt texts is mandatory. If they are not 
entered properly, you will not be able to share the images. 
 

 
 
 
 
 

 

 

 

3.2 Create teaser boxes 
 When using the images, please ensure that you have clarified the rights of use: 

Copyright of the photographer and personal rights of the persons depicted. 
 

 Customize the images: jpg format, RGB colors, 1100 pixels (px) width by 440 pixels 
height (crop with e.g. Gimp or Photoshop). The image should be under 300 KB, 
otherwise the loading time of your website will increase. 
 

 In the CMS, switch to your pool folder in the column view. There, select the "Teaser" > 
"teaserbilder" folder. 
 

 Import the images one by one into the selected folder: "File" > "Import File" > "Create a 
new file in the folder 'teaserbilder'"; via "Datei auswählen" (Browse) select the image to 
be uploaded and "Import" > select template "UNI-BT image" > customize "Name" and 

Figure 24: Edit slider 
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"Title", e.g. teaser-research, teaser-news and teaser-contact.  
 

 Add the "unibt_alttext" to the teaser images (see Chapter I.7.3.) 
 

 Now select the folder "inhaltsteaser_3sp" and create a new teaser via "File" > "New 
Document" > Template "unibt_teaser_element". Then switch to the Preview ("Eye"). 
Now edit your teaser boxes by adding text and linking an image under 
"Teasereinstellungen bearbeiten" (Edit teaser settings) as well as adding a link to a 
subpage/external page. 
 
Note: The teaser images will be displayed later on the live page only if a link is stored in 
the corresponding field of the teaser.  

 

Figure 25: Teaser box in the preview 
 

 

Figure 26: Options under „Teasereinstellungen bearbeiten“ (Edit teaser settings) 

 Then switch back to the column view, release your teasers (see Chapter I. 9.1.) and go 
back to your start page folder "de" or "en". Under the page properties you will find the 
block "Teaser". Here you can link a teaser box for each column. 
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Figure 27: Linking teaser on a start page 

3.3 Customize start page text 
 

Under the page properties in the column view you will find the "Fields" block. Here you can 
insert your start page text in the "Main Content". Please keep it rather short and write your 
notes as HTML. Finally, click on "Ok". 

 

Figure 28: The start page text is edited in the “Main content". 
 

Note: If you have only one slider image, its text replaces the start page text under "Main 
content".   
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Chapter III - Designing standard pages 

1. Create default page 
 
 Create a new folder in the column view below your start page: "File" > "New folder" > 

Name (as concise a keyword as possible, lower case: e.g. research), select the template 
"unibt_standard" and confirm with "OK" > enter the desired heading in the "Title" line 
 

 Now specify under "Overview" > "flipside" whether the page should be findable via the 
menu (if not: "btcms_menu_ausblenden" > "ja"), what the Short title for menu or 
breadcrumb (“btcms_kurztitel”) should be called and whether there is a link to a 
linguistic counterpart (“unibt_siblinglink”) (= English or German version of this page)..  
 
Note: For bilingual pages, you must always link from the German page to the English 
page and from the English page to the German page. 
 

 

Figure 29:  Settings of a standard page 

 You can edit the arrangement of menu items in the preview. Move the mouse over the 
menu item you want to move. A cursor appears with which you can drag and drop the 
items into the correct order. 
 

 

Figure 30: Changing the order of menu items in the preview 
 
 
 
 

2. Insert banner images 
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Banner images give structure to the (sub)page. If no banner image is linked, the headline is 
visually separated from the rest of the page with the help of a gray bar..  

Note: On standard pages no sliders are possible, on pages with the templates 
"unibt_event_uebersicht", "unibt_blaupause_newsordner" and "unibt_publikationen" also 
no banner images are possible. 
 

Option 1: Standard page with banner image 

 

 

Option 2: Standard page without banner image  

 

 

 

 

 

 

 

 
 

 

Create banner image: 

 Create a new folder "bannerbilder" in the pool under "bilder": "File" > "New Folder" > 
assign name, select “btcms_hidden” template. 
 

Abbildung 311: Standardeite mit Bannerbild 

Abbildung 322: Standard page without banner image 
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 Crop original photos (e.g. with Gimp or Photoshop): jpg format, RGB colors, 1100 pixels 
(px) width by 440 pixels height. The image should be under 300 KB to keep your 
website loading time low. 
 

 Import selected banner images into the newly created banner images folder: "File" > 
"Import file" > select "Create a new file in the folder 'bannerbilder' " > "Datei 
auswählen" (Browse) > select image > "Import" > select "unibt_bannerbild_element" 
template > adjust "Name" (e.g. bannerimage_research) & "Title" (bannerimage 
research) accordingly. 
 

 An "Alt text" must be added to the respective image under "Overview" > “flipside” in 
the column view (see Chapter I.7.3). It describes what can be seen on an image. 
Maintaining the alt text serves search engine optimization (SEO) and the accessibility of 
the pages. It is mandatory to fill it in, i.e. changes to the image cannot be released if the 
alt text is not filled in. 
 

 Finally, release the banner image you just uploaded.  

Link banner image: 

 Select the desired default page in the column view. 
 

 In the Overview under "Flipside" you can now link the banner image. The link target is 
the banner image that was previously stored in the pool under "images" > 
"bannerbilder". 
 

 

 

 

3. Edit page properties 
 
Stay in the column view and look at the field „Flipside“ under „Overview“ (right side). Here 
you can edit different page properties:  

 Show or hide menu item (see Chapter III.1) 
 

 Set a "Short title for menu or breadcrumb" (btcms_kurztitel). Make sure to use short 
keywords, such as research, teaching, news, publications, etc. 
 
Note: If no short title is maintained, the heading will be displayed automatically in the 

Figure 33: Linking the banner image on a default page 
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breadcrumb menu and the left-hand menu column.  
 

 Set a "Language switcher": For websites with both German AND English languages, you 
must link to the corresponding language page under "unibt_siblinglink". If you fail to 
do so, when you click the language switcher later, you will be directed to the starting 
page instead. 
 
For websites with only one language, you only need to include a corresponding notice 
in the "de" or "en" folder (see Chapter II.1.1, Special case of single-language websites), 
but not on subpages. 

 

Figure 34: Flipside-Settings of a standard page 

 

 

 

 

 

4. Page layout  
As described in Chapter I.8, you have the option to design your page using text-image 
modules, accordion modules, and link list modules. However, there are also additional 
modules that we will introduce to you below. 

4.1 Image gallery module 
Here you have the option to insert multiple images simultaneously and side by side on 
your standard page. 
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Figure 35: Image gallery 

 Preparation: Compress the images to a size ideally under 300 KB and save them in jpg 
format. Then, place the images in a ZIP file: select the images > right-click with the 
mouse > "Send to" > "Compressed (zipped) folder". 
 
Note: This guide is for Windows and may vary for other operating systems! 
 
Please note that only the images are in the ZIP file and not another folder or other files. 
 

 Create an image gallery: Switch to the CMS and the column view. Select the standard 
page where the gallery should take place. Then click on "File" > "Import archive", select 
the ZIP file and let it "Extract to a new folder"; confirm with "OK". Then select the 
template "UNIBT: Galeriemodul" and click "Close". 
 

 The images are automatically imported with the image template "UNI-BT Image". Only 
with this template can you add "Copyright" and "Alt Text". Please note that the Alt Text 
is a required field. More information about Alt Text can be found in Chapter I.7.3. 
 
To add captions, Alt Text, and copyrights for the gallery images, stay in the column 
view. Select the respective image and enter the corresponding data under "flipside". 

 

Figure 36: Settings of a UNI-BT standard image 

 

4.2. YouTube-Videos 
 

YouTube videos can be embedded (not uploaded!) directly on the website. 
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Note: Be aware that due to the General Data Protection Regulation of May 25, 2018, we 
must embed YouTube videos in compliance with data protection regulations. YouTube 
itself offers the possibility to generate embed codes that do not set cookies. 

Proceed as follows:  

In the CMS, select the column view and the standard page on which the video should be 
embedded. Now insert the corresponding module: "File" > "New Document" > enter name 
> select template: "unibt_video_module" > confirm with "OK" > do not fill in "Flipside" 

Go to YouTube and select the corresponding video > click on "Share" > select "Embed" > 
scroll down and check "Enable privacy-enhanced mode" > copy the YouTube link from the 
iframe code (https://www.youtube.com/embed/xyz, copy without quotes) 

 

Figure 37: Privacy compliant YouTube embed code 

Switch back to the CMS to the column view. There, paste the link you copied earlier into 
the YouTube Video Embed Link field. 
 

 

Figure 38: Paste Embed-Code 

In the Editor view you can determine the placement of the video on the page. 
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4.3. Google Maps 
 

Google Maps maps can also be embedded on your website.  

Proceed as follows:  

In the CMS, go to the column view and select the standard page on which the map is to be 
embedded. Now insert the corresponding module: "File" > "New Document" > enter name 
> select template: "unibt_map_modul" > confirm with "OK" > do not fill in "flipside". 

Now go to Google Maps and search for the desired address > click on "Share" > tab 
"Embed Maps" > copy URL from https:// to the end of the quotation mark:

 
Figure 39: Copy the Google Maps embedded link 

 

Switch back to the CMS to the column view and paste the link under "Content" > "Free 
Links": 

 

Figure 40: Paste the embedded link 
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4.4 CAMPUSonline interface for courses  
 

You have the option to include an interface to CAMPUSonline on your website and thus 
automatically display the current courses. This way you save yourself double maintenance.  

 

Figure 41: Courses embedded on a website 
 
 

To do this, go to the column view and select the default page where you want to include 
the courses.  

Go to "File" > "New document". Select the template "unibt_CoursesWithSemester_modul", 
assign a name and confirm with "OK". 
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Switch to CAMPUSonline and find your chair code. To do this, go to your chair and then to 
"Lehrangebot". You will find the code under "betr. Org.", e.g. Fak1L_LMa5.  
 

 

Figure 42: Display of chair codes in CAMPUSonline 
 

 

Switch back to the CMS to the column view. Under "Overview" > "Flipside" there is the field 
"coursesWithSemesterUnitComplex". Insert the code there with square brackets and single 
quotes, for example: ['Fak1L_LMa5']. If you want to insert multiple chair codes, this must be 
done comma separated, for example: ['Fak1L_LMa5','Fak2L_LGen'].  
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Chapter IV - Special pages 
 

1. Publications 
 

Publications are integrated using ERef and automatically generated as a list in the CMS. 
This requires an xml link from ERef. To get this xml link, you have to enter your publications 
via your ERef account.  

General information about ERef: 
 

 ERef FAQs: https://eref.uni-bayreuth.de/help/index.html 
 Advantages of using ERef: ERef Bayreuth increases the visibility of the scientific output 

of researchers at the University of Bayreuth by integrating it into the international 
network of Open Archive Servers. The content is thus searchable via central reference 
tools such as OAlster, BASE, Google Scholar, etc. 

 The contact for ERef matters is the Bayreuth University Library: www.ub.uni-
bayreuth.de  

Embedding your publications via ERef-xml link:  
 

 Maintain your publications in ERef: https://eref.uni-bayreuth.de  
 Go to ERef. click on "Browse" and pick your appropriate institution/chair/person.  

 

 

Figure 43: ERef start page 

 At the end of each list you will see an xml link that can be included in websites. Copy 
this.   

 

Figure 44: xml link in ERef 

 

 

https://eref.uni-bayreuth.de/help/index.html
https://eref.uni-bayreuth.de/
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 Switch to the CMS column view and create a new page: "File" > "New folder" > assign 
name (e.g. publications) & select template "unibt_publikationen > confirm with "OK" > 
enter the desired heading (e.g. publications) in the "Title" line > confirm with "OK".  
 

 Paste the xml link from ERef: "Overview" > "Flipside" > 
"profil_mitwirkende_publikationen". 
 

 Again, add a "short title" if needed. 
 

 If you would like a heading other than "Publications", please maintain the desired title 
under "Publications Heading".  
 

 If you want to sort by years, please maintain the following in the "unibt_json_config" 
field:  { "list": { "order1": "years" }  } 
 

 You can get a sort by publication type by using the following command: { "groups": { 
"monographs": "book", "article in a journal": "article", "essay in a book": "book_section", 
"newspaper article": "article_paper", "event paper": "conference_item", "review": 
"review", "preprint": "preprint", "working paper": "working_paper", "project reports": 
"report", "contribution to a legal commentary": "legal_commentary", "translation": 
"translation", "encyclopedia article": "encyclopedia", "patent": "patent", "full journal 
issue": "periodical_part", "editor of a journal": "series_editor", "online contribution": 
"online", "dissertation": "thesis", "habilitation": "habilitation", "bachelor thesis": 
"bachelor", "master thesis": "master"}, "list": { "order1": "groups" }  } 
 

 

Figure 45: Setting options of a publication blueprint 

 

If you want to fine-tune the display of your publications, you can also do this via the 
"unibt_json_config" field.  

You can get an impression of the filtering options here:  
https://www.bayceer.uni-bayreuth.de/eref/.  
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2. team representation 
 

You would like to introduce yourself and your team? No problem. Fiona 7 offers various 
options for this:  
 

2.1. standard page with text-image modules  
 
With this procedure you simply represent your team members on a UNI-BT: standard page 
(unibt_standard) via text-image modules. You will find instructions in chapter I.8.1. 

 
Figure 46: Team overview with text-image modules 
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2.2. standard page with accordion and photo 
 

With this procedure you simply represent your team members on a UNI-BT: standard page 
(unibt_standard) via accordion modules. You will find instructions in chapter I.8.3. 

 

Figure 47: Team overview with an accordion module 

2.3. team presentation with overview page and detail pages  
 

The most extensive and maintenance-intensive variant is the team presentation by means 
of detail pages. Here, the CV, the research and teaching focus, the publications and the 
contact are indicated. If a tab has no content, the tab is not displayed. For example, 
professors can be displayed extensively with their CV and publications, while secretarial 
staff or student assistants can only be displayed with contact details.  

 

Figure 48: People overview in list form and people details page 

 Cut the portrait images to square, e.g. to the dimensions 500 pixels x 500 pixels (jpg 
format, RGB colors) and store the photos in the pool under "bilder" (for procedure, see 
Chapter 7.1.). Use the template "unibt_bild" and maintain the "Alt text" and the 
"Copyright".  

 Create a new page in the column view below your start page: "File" > "New folder" > 
Name folder (e.g. team), select template "unibt_mitwirkende" and then confirm with 
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"OK". > Enter "Team" in the "Title" line and confirm with "OK".  
 

 In the next step, you create the individual people: Click on the "Team" folder you just 
created > "File" > "New folder" > Name (e.g. mustermann-max), select template 
"unibt_person" and confirm with "OK" > Under contact details, enter name, faculty, 
department, function, address, e-mail address, telephone and confirm with "OK".  
 

 Enter the name of the person in the Overview under "Common" for "Title" and under 
"Flipside" for "btcms_kurztitel". Under "verantwortlich" (responsible) enter the bt-
identifier of the person who is responsible for the maintenance of the person pages. 
Please make sure that the person is employed at the University of Bayreuth for a longer 
period of time.  
Note: Group identifiers (bt4...) are not possible here. 

On person pages you have different tabs available for your information: 

 Kontaktdaten: The Contact tab is already present filled in if you specified the contact 
details when creating the person page. 

 Profile: In the column view you can link the xml link from ERef for the corresponding 
person (cf. chapter IV.1.) 
 

 

Figure 49: Insert xml link at person page 
 

 Person: Now switch to the editor view ("Eye") and complete the curriculum vitae under 
the Person tab. In the editor you will find so-called mini-templates (=preformatted 
tables). Click into the text field so that the formatting bar opens. On the far right you 
will find these templates. The mini-template is called "Tabelle für Berufserfahrungen” 
(Work Experience Table). 
 

 

Figure 50: Mini templates can be accessed via the formatting bar 
 

 Schwerpunkte: Add the person's research or teaching focus here, e.g. as a bullet point 
list. 
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3. News 
 
 Create a new page in the column view below your start page: "File" > "New folder" > 

Name (e.g. news), select the template "Blueprint news overview" and confirm with "OK" 
> Assign "Title" (e.g. News) and confirm with "OK 
 

 Below the news folder, year folders must be created, e.g. "2022": "File" > "New folder" > 
Name (e.g. 2022), select template "unibt_blaupause_newsordner" and confirm with 
"OK" > Assign "Title" (e.g. 2022) and confirm with "OK". Under "Valid from" must be the 
first day of the year, so in the case of 2022 01.01.2022.  
 
Attention: Hide this folder as a menu item: Select "Ja" in the column view under 
"Flipside" at the item "btcms_menu_ausblenden". If you do not do this, the folder will 
appear as a menu item, but will not display any news messages there.  
 

 Below the respective year folder, the news objects can now be created: "File" > "New 
folder" > Name (scheme: year-month-day_newsname), select template " 
unibt_blaupause_newsmeldung " and confirm with "OK" > Assign "Title", e.g. "Press 
release: Start for new master program Environmental Geography" and confirm with 
"OK 
 

 Stay in the column view and enter the following scheme in the Overview under "Fields" 
> "unibt_presse_datum_prosa": "Keyword, Day.Month.Year". 
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 Hide the menu item under "Flipside" again, insert a "btcms_kurztitel" (short title) and 
add the "unibt_presse_datum" (press date). It is used for sorting in the list overview and 
is the publication date of the news item.  
 

  

Figure 51: Settings of a news template 
 

 Now switch to the editor view ("Eye") to set the main content of the news item. Add as 
many text-image modules as you like using the module center (procedure: see Chapter 
I. 8 f.f.).  

 

 

 

 

 

4. events/dates 
 Create a new page in the column view below your start page: "File" > "New folder" > 

Name (e.g. appointments), select the template "unibt_event_uebersicht" and confirm 
with "OK" > Assign "Title" (e.g. appointments) and confirm with "OK 
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 Below the event folder, another folder must be created: Click on the event folder you 
just created and create the archive folder: "File" > "New folder" > name "archive", select 
template "unibt_event_uebersicht" and confirm with "OK".  
 

 You do not need to enter events below the archive folder. The CMS automatically sorts 
past events under the "zurückliegende Termine" list when displaying the list on the 
web.  

 

Figure 52: Overview of past events 

 Below the event folder you can now create your events:  File" > "New folder" > Name 
(scheme: year-month-day_event_name), select the template "unibt_event" and 
confirm with "OK" > Assign "Title" (e.g. show lecture Prof. Dr. xyz) and confirm with 
"OK". 
 

 In the column view, go to the folder you just created and enter a bt identifier in the 
Overview under "verantwortlich". In addition, add the short title of the event under 
“btcms_kurztitel”, Date and time under “profil_termin_startdatum”and the Location 
under “profil_termin_ort”, all found under"flipside". The start date is used for sorting in 
the event list. Please enter the day of the event here via the displayed calendar. 
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Figure 53: Overview of an event 

 Now switch to the editor view ("Eye") to specify further appointment details such as the 
program or to link a PDF. One text-image module is already created. But you can add 
more via the module center. Accordion and link list modules are also conceivable for 
events.  
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Chapter V - Check & Set On/Offline 
1. check the contents 
When you are done with your changes, always check your entries in the Separate Preview. 
To do this, either use the icon or go to View > Separate Preview. A new browser tab or 
window will open. This gives you a live preview of your page, where you can test links, for 
example. Editing is not possible in this view. 

Note: If you do not allow external links to open in a new tab/window, contrary to the 
recommendation, you will not be able to test the link in the preview. 
 

 

Figure 54: Separate preview icon 

 

2. online jobs 
 
 Before newly created pages can go live, please contact the online editorial team 

(onlineredaktion@uni-bayreuth.de). As part of a quality assurance loop, they will briefly 
review your page, help with formatting errors or problems, and possibly make 
recommendations. The online editorial team will also be happy to assist you with page 
redirection of your existing URL, applying for a security certificate (SSL encryption) or 
applying for a subdomain. 
 

 There are various options for putting your files online. You can read more about this in 
the first chapter under I.9. 
 

 

3. take files offline 
 

 To take your files offline, select the respective folders and items and take them offline 
via "Workflow" > "Retract".  

 You can take several items offline if you switch the view first: "View" > "List" > select 
files > "Workflow" > "Unrelease". 

 To put your files online, go to "Workflow" > "Finish Editing". A new window will open 
showing you all the files you have edited. Mark the desired files with a check mark. Click 
on "Next" and confirm with "OK". You do not need to add a note. 

 

4. deactivate files 
 

mailto:onlineredaktion@uni-bayreuth.de
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Sometimes it also makes sense to deactivate files. This is especially the case if the 
corresponding file should automatically go offline at a certain time, for example with the 
news.  

To do this, proceed as follows: In the column view, select an end date in the properties 
under "Fields" > "Valid until". At this point, the file goes offline. You can easily reactivate it 
later by extending or completely removing the information under "Valid until". 

Alternatively, you can take files offline directly via Workflow > Deactivate or Workflow > 
Unrelease. 

 

 

Chapter VI - Sample Pages 
 

Chair template 

... used by chairs 

https://www.retsch.uni-bayreuth.de/en/index.html 

https://www.enders.uni-bayreuth.de/en/index.html  

https://www.lup.uni-bayreuth.de/de/index.html 

 

... used by courses of study 

https://www.he.uni-bayreuth.de/en/index.html  

https://www.sporttechnologie.uni-bayreuth.de/de/index.html  

 

... used by specialist groups 

https://www.afrikanistik.uni-bayreuth.de/en/index.html 

 

...used service points and central facilities 

https://www.schreibzentrum.uni-bayreuth.de/de/index.html 

 

 

...used for event pages 

https://www.unikat.uni-bayreuth.de/de/index.html 

 

https://www.retsch.uni-bayreuth.de/en/index.html
https://www.enders.uni-bayreuth.de/en/index.html
https://www.lup.uni-bayreuth.de/de/index.html
https://www.he.uni-bayreuth.de/en/index.html
https://www.sporttechnologie.uni-bayreuth.de/de/index.html
https://www.afrikanistik.uni-bayreuth.de/en/index.html
https://www.schreibzentrum.uni-bayreuth.de/de/index.html
https://www.unikat.uni-bayreuth.de/de/index.html
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Faculty template  

... used by faculties 

http://www.bcg.uni-bayreuth.de/de/index.html  

https://www.split.uni-bayreuth.de/de/index.html 

 

... used by specialist groups 

https://www.wi.uni-bayreuth.de/de/index.html 

 

... used by central facilities 

https://www.obg.uni-bayreuth.de/de/index.html  

https://www.sz.uni-bayreuth.de/de/index.html 

 

...used for study programs 

https://www.goe.uni-bayreuth.de/de/index.html 

 

http://www.bcg.uni-bayreuth.de/de/index.html
https://www.split.uni-bayreuth.de/de/index.html
https://www.wi.uni-bayreuth.de/de/index.html
https://www.obg.uni-bayreuth.de/de/index.html
https://www.sz.uni-bayreuth.de/de/index.html
https://www.goe.uni-bayreuth.de/de/index.html
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